Blackthorn Messaging - Outage Impacting Ability to Send Messages
Incident Report for Blackthorn
Postmortem

After further investigation, our engineering team has identified the root cause.  It appears the Database supporting production services reached it's limit preventing customers from being able to send messages.

This service had to be expanded to restore messaging, and should continue working as expected. Moving forward, Autoscaling and monitoring tools will be enabled as part of the resolution so this shouldn’t happen again.

Posted Mar 12, 2024 - 15:34 UTC

Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 21:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2024 - 21:54 UTC
Update
Our Blackthorn Messaging App service has now been restored. We are currently monitoring the situation but please reach out to Blackthorn Support at https://community.blackthorn.io/s/support-request if you run into any issues going forward.
Posted Mar 11, 2024 - 21:51 UTC
Update
Messaging App service is being restored, and we will confirm when this is complete. We are continuing to monitor the situation and will also provide a Root Cause Analysis regarding this issue.
Posted Mar 11, 2024 - 21:35 UTC
Investigating
Our Engineering team is currently investigating an issue relating to the inability to send messages. We will provide updates here as the investigation continues.

Thank you for your patience as we urgently work to restore SMS deliverability.
Posted Mar 11, 2024 - 20:05 UTC
This incident affected: Blackthorn Messaging.