Blackthorn Events
Incident Report for Blackthorn
Resolved
This incident has been resolved.
Posted Jun 21, 2023 - 12:55 UTC
Update
Service for Blackthorn Events is restored to all regions.
Posted Jun 21, 2023 - 12:54 UTC
Investigating
We are working to complete a maintenance event that has caused a temporary outage.

Service will be restored momentarily.
Posted Jun 21, 2023 - 12:49 UTC
This incident affected: Blackthorn Events.