Event Pages and AttendeeLink Performance Impact
Incident Report for Blackthorn
Resolved
This incident has been resolved. We have increased available resources and site loading times have returned to normal. We are continuing to monitor the situation.
Posted Mar 15, 2022 - 23:39 UTC
Update
We are continuing to work on a fix for these intermittent outages. Please note this is currently our engineering team's highest priority and we will follow-up as soon as this has been resolved.

Please find action items being taken by our engineering team below:
- We are increasing the number of dynos (servers) available to us so that we can scale more horizontally.
- Smoke and Stress testing is in development so that we can define more limits and understand more deeply what’s going on when we have these issues.
- Further improvements to caching and load balancing are forthcoming.

Thanks so much and we again sincerely apologize for these ongoing issues.
Posted Mar 15, 2022 - 22:36 UTC
Identified
After further investistgation, Blackthorn has identified the root cause of these intermittent outages Event pages due to unusually high levels of traffic.

Our engineering team is working on further load balancing and additional capacity over the next few days. Please note this currently our team's highest priority and we will follow-up as soon as this has been resolved.
Posted Mar 15, 2022 - 20:40 UTC
Investigating
Users have reported experiencing intermittent errors with Event Pages and AttendeeLinks and our developers are closely monitoring app traffic. Users may experience a 400 error or slow loading times when accessing Event Pages or AttendeeLinks.
Posted Mar 15, 2022 - 17:58 UTC
This incident affected: Blackthorn Events.